Support cPanel: si passa a PHP 5.5 (e non solo)


Postato in data marzo 24th, da Riccardo Esposito in News. No Comments

La notizia è nota dallo scorso dicembre: cPanel, storico pannello di controllo grafico per la gestione e l’amministrazione di siti e hosting, terminerà ufficialmente il supporto per PHP 5.2 e 5.3. Obiettivo? Passare alla versione 5.5.

cpanel

Il motivo di questo abbandono? Semplice: lo sviluppo delle versione di php precedenti alla 5.5 è terminato, non sono disponibili altri aggiornamenti per la sicurezza.

cPanel chiude il supporto per Apache 1.3/2.0 – il rilascio dei fix sicurezza è terminato – e annuncia anche la sospensione del supporto per MySQL 5.1 (per maggiori informazioni su questo argomento puoi consultare la sezione dedicata).

Il passaggio a MySQL 5.5 è particolarmente importante (anzi, è obbligatorio): il cPanel che avrà ancora MySQL 5.1 non invierà aggiornamenti al sistema.

mysql

 

Ovviamente, l’aggiornamento di MySQL comporta la ricompilazione di Apache e PHP. Le versioni 5.1 e 5.2, però, non saranno presenti nelle opzioni di scelta su EasyApache.

Come risolvere?

Passando alla versione 5.3 (ma anche questa ben presto terminerà il supporto), 5.4 o 5.5. L’aggiornamento può essere eseguito dal WHM cliccando su “MySQL Upgrade”. Ecco i passaggi:

  • Home
  • Software
  • MySQL Upgrade

Ricorda che ad aggiornamento concluso dovrai ricompilare subito anche PHP con EasyApache. Prima di passare ad una versione successiva di php 5.2, devi assicurarti che il CMS sia compatibile con l’aggiornamento.

In particolar modo devi controllare le nuove funzioni e le differenze tra le varie versioni

Per quanto concerne WordPress, dalla versione 3.8 ha piena compatibilità con php 5.5. L’aggiornamento può essere messo in pratica dal pannello di amministrazione nella sezione “Aggiornamenti”. Niente di più semplice!

wordpress

Joomla 1.5, invece, non è completamente compatibile con php 5.5 ed è necessario aggiornare il CMS alla 3.x. Per informazioni su come aggiornare la piattaforma puoi consultare questa pagina.

Anche la versione 2.x di Joomla non è completamente compatibile con la nuova versione di PHP.

Altri CMS

La versione 7 Drupal è quasi completamente compatibile (ci potrebbero essere alcuni errori php da risolvere a mano), mentre la 8 è perfettamente in linea. Magento: tutte le versioni successive alla 1.5 sono compatibili con php 5.5, le successive no. Soluzione simile per Prestashop: tutte le versioni successive alla 1.5.6.0 sono compatibili.

Riccardo Esposito

Blogger per Serverplan, webwriter freelance e autore di My Social Web. Scrivo ogni giorno. Ho pubblicato un libro dedicato al mondo del blogging. Ah, l'ho già detto che scrivo?




Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

*

Shares